
Integration in Ability
Integration is a term used to describe how different applications work together and especially how they 

share data.

There are three main ways Ability can share information:

1.       Copy and paste   – a simple copy of data from one application to the next.

2.       Linking through fields   – sharing data through linking with fields. Data remain live so that when the 
source is changed, the linked fields change also. Mail Merge is the most obvious example of field 
level integration.

3.       Embedding and linking documents   – whole documents, or a selected part of a document, can be 
inserted into another application. For example:

· Include spreadsheets and charts into Write

· Include drawings into Write and Spreadsheet

· Include Write documents into Spreadsheet

See also:

Fields - an introduction 

Mail merge 



Copy and paste
In general, you can select any text, data or formulas and make a copy for insertion into another – or the
same – document. Ability has commands that enable you to Copy, Paste and Cut data. If you want to 
copy data to another location without retaining the original source data, then use Cut instead of Copy. 
Here are the basic steps:

1. Select the data you wish to copy using either the mouse or cursor keys. This might be the contents 
of an individual cell or range in a spreadsheet or database, whether text, data or formulas, or an 
area of a Write document.

2. Click on the Copy button  or select Copy from the Edit menu. This command copies to the 
Clipboard.

3. Switch to the application that contains the document to which you wish to copy.

4. Click on the Paste button  or select the Paste command from the Edit menu. This copies from 
the Clipboard to the target document.

Once the Paste command has been issued, there is no further link between the copied data in the 
target document and the contents of the clipboard or the source of the data. It is as if you have retyped 
the data, but much quicker. The contents of the clipboard remain unchanged until you copy some other 
data to it.

Most of the Ability applications –Write, Database, Spreadsheet – support rows and columns. When you 
copy data from one application to another, the rows and columns are preserved. This is obvious with 
Database and Spreadsheet, which are defined in term of fields and cells, but less so with Write, in 
which a row is represented by a paragraph and a column by a tab stop. For example,

Jan Feb Mar Apr
12 13 9 7

has four columns (since the months and numbers are each separated by pressing the Tab key) and 
two rows.

See also:

Examples of copy and paste 

Copy and paste in dialogs 



Examples of copy and paste

Here are some examples of what you can do with Copy and Paste:

· Database è Spreadsheet

Select the rows and columns (the range of fields) you want to copy from the database and copy 
and paste into a spreadsheet. Ability will preserve the order of the rows and columns and every 
field from the database will appear in a different spreadsheet cell.

· Database è Write

Select the rows and columns (the range of fields) you want to copy from the database, and copy 
and paste into a Write document. Each column is separated by a tab stop and each row begins on 
a new line.

If the database row is too long to fit on a single line in the Write document and "wraps around" onto 
the next line, try bringing the tab stops closer together and/or reducing the font size.

· Write, Spreadsheet è Database

This is the reverse of the above two operations and ideally the number of columns in Spreadsheet 
– or the number of tab separated columns in Write – should match the number of fields (columns) in
your database (if not, you may find fields from different records merge into a single record).

· Write è Spreadsheet

Select the text you wish to copy: this can be a word, a line or several paragraphs. When you paste 
into Spreadsheet, tabs will begin new columns and paragraphs new rows. Use Paste Special from 
the Edit menu and select Unformatted Text.

See also:

Copy and paste in dialogs 



Copy and paste in dialogs

As well as using copy and paste to transfer data between applications, you can copy and paste into 
dialog boxes and formula entry lines. You will need to make use of the shortcut keys to do this:

Ctrl+C Copy

Ctrl+V Paste

For example, in the text of a Write document there appears the name of another document, say, a 
spreadsheet called Figures. To copy and reuse the word "Figures": 

1. Select it by double-clicking on it.

2. Press Ctrl+C to copy it.

3. Switch to Spreadsheet.

4. Click the Open button . 

5. Press Ctrl+V to paste it into the File name box.



Linking through fields
One of the most powerful features of Ability is the capacity for a field in one document or application to 
refer to a field in any other Ability document or application. Such a relationship is called linking and can 
take two forms: one way linking and two way linking:

1. A one way link is used to access data in the current document that is located in another document. 
The data can be displayed or used in a formula, but cannot be changed unless you open the 
original document. A one way link can be made between documents in different applications.

2. A two way link allows you to change data at either end of the link. This means that the original 
document is updateable from the target document, though two way links cannot be used in 
formulas.

Linking can be used to connect these documents:

· Cells in a spreadsheet to another spreadsheet, write document or database form.

· Fields in a database to a spreadsheet or write document.

· Fields in a write document to another write document, spreadsheet or database form.

For a general discussion on fields, see fields - an introduction.



One way links

To create a one way link, you need to know the name and the location of the document to which you 
want to link. With a Write document or spreadsheet you need to know the name of the field or cell 
address whose value you want to access. If you want to link to a database you also need to know the 
table or query name, along with the field name and record number. 

The link is created using one of the Remote functions. The remote functions you will most often need 
are:

WPGET(document_name, reference) Retrieve field from Write

SSGET(document_name, reference) Retrieve field from Spreadsheet

DBGET(database_name, 
source_table, field_name, record)

Retrieve field from Database

When you enter a remote function in a field in the current document, you need to specify the following:

1. Name and path of the remote document or database (otherwise the current folder will be 
searched).

2. Name of the field in the remote document, whose value is sought.

3. When linking to a database, you will additionally need to supply the table name, field name and 
record number.

As well as returning single values, all field links can be used to return ranges, which can then be used 
to provide range totals, maximums, minimums and so on.

See one of the following examples:

Linking two spreadsheets together 

Linking two Write documents togther 

Linking from a Write document to a spreadsheet 

Linking from a spreadsheet to a database 

For more on Remote functions, see function reference.



Linking two spreadsheets together

To create a one way link from a spreadsheet called accounts to a cell, say B10, in a spreadsheet called
sales follow these steps:

1. Select a cell in sales where you'd like the value from accounts to appear, say A1.

2. Click in the formula entry line.

3. Click on the Insert Function button  to bring up the Insert Function dialog.

4. Click on Remote tab and scroll through to select the SSGET function.

5. Select OK to pick the function.

6. Enter the function parameters so the formula appears as follows:

=SSGET ("sales", "B10").

7. Click OK  to finish the formula.

Ability will display the value from the sales spreadsheet inside the accounts sheet.

Once the link has been made, the cell can be referenced like any other. For example, the formula:

=A1 * 2
in the accounts spreadsheet will simply display the value, originally from sales, doubled. 

You can also use the SSGET function directly as part of a formula. For example:

=(10 + SSGET("sales", "B10"))/2
Note that the function parameters must be placed in quotation marks. Also, the example assumes that 
the two spreadsheet documents are in the same folder. If they are not, then you must specify the full 
document path. For example

=SSGET("c:\my documents\sales", "B10")
if sales was stored in the default document folder.

Any change made to B10 in sales will automatically be reflected in A1 of accounts. However, since this 
is a one way link, the attempt to enter a value in A1 of sales will overwrite the link formula and hence 
destroy the link (see two way links if you want to enable this feature).



Linking two Write documents together

To create a one way link between a field, say janprofits, in a Write document called report, and a field,
say monthtotal, in a Write document called annuals, where the link is from report to annuals, take the
following steps:

1. You first need to create a field in report. Select Field from the Insert menu. Enter janprofits for the
field name (which is more descriptive than the default name of Field1) and click the Next button 
and enter 1276.34 as the field contents in the Formula entry line. Click the Finish button.

2. Switch to annuals and click where you want the field to appear. Select Field from the Insert menu. 
Enter monthtotal for the field name and click the Next button. Click the Functions button and 
select WPGET from the Remote function category. Enter the document name and field name into 
the function so that the formula appears as follows:

=WPGET("report", "janprofits")

Click the Finish button

3. The field will appear in the document. Click outside the field to activate the one way link. The value 
from the report document, 1276.34, will appear in the document.

Note that the example assumes that the two documents are in the same folder. If they are not, use the 
full document path of the source document. For example

=WPGET("c:\my documents\report", "janprofits")



Linking from a Write document to a spreadsheet

Suppose you have a sales spreadsheet with monthly sales figures. You want to include the highest 
monthly figure and the total sales for the year into a Write document. The spreadsheet is called sales97
and the figures you need run from C1 to C12. The figures need to appear in the middle of a paragraph 
like this:

"The average monthly sales for 1997 was $xxxx.xx with the highest single month topping out at 
$xxxx.xx."

Follow these steps to link from the Write documents and extract these figures:

1. In the Write file, type the text of the paragraph. Leave a space where the fields need to be inserted.

2. Position the cursor between the words "was" and "with".

3. Select Field from the Insert menu.

4. Click the Next button (if you want, you can enter a more meaningful field name on the first page of 
the wizard).

5. Enter the following formula:

=AVG(SSGET("sales97", "C1..C12"))
6. Click Finish
7. Position the cursor at the end of the paragraph and repeat steps 3 through 6 using the following 

formula:

=MAX(SSGET("sales97", "C1..C12))
Note that the example assumes that the two documents are in the same folder. If they are not, use the 
full document path of the source document. For example

=MAX(SSGET("c:\my documents\sales97", "C1..C12"))



Linking from a spreadsheet to a database

Suppose you have a database called accounts containing a table called invoices. Among other fields 
in the database table, there is a field for the total of the invoice, invtotal, one to identify the customer, 
custid, and two more for the date of the invoice and the date it was paid, invdate and paydate. The 
particular customer you are interested in has a custid of 1024. In a spreadsheet, you want to analyze 
their payment history, perhaps plotting a graph showing the payment trend. Follow these steps:

1. Display the first invoice total: Enter the following formula:

=DBSQLFILTER("accounts.adb", "invoices", "custid=1024", "invtotal", 1)

Let’s explain this in some detail. The first two parameters to this function are simply the database 
name and the table name – note you need to include the document extension with the database 
name (adb). The table contains invoices to many customers, so you have to identify which 
customer you want to return values for – this is done with the third parameter to the function – 
"custid=1024". Next, we specify which field is to be returned with the third parameter – invtotal. The 
function actually returns all the fields matching the condition so we need to say which one is to be 
displayed. The final parameter says "display record 1".

2. Display the invoice and payment dates. In the cells to the right of the invoice total, enter the 
following two functions:

=DBSQLFILTER("accounts.adb", "invoices", "custid=1024", "invdate", 1)
=DBSQLFILTER("accounts.adb", "invoices", "custid=1024", "paydate", 1)

3. Repeat steps 1 and 2 the rows below, incrementing the record number (the fifth parameter) by one 
each time, until all the matching invoices are displayed.

4. You can now analyze the data in several ways. Here are two examples:

Produce an average payment period by subtracting the invdate column from the paydate column 
and dividing by the number of invoices.

Plot a bar chart of the number of days it takes to pay each invoice (again by first subtracting the 
invdate column from the paydate column).

There are a number of ways this example can be improved and made more general (so it will work 
easily for other customers) – see refining database links 



Refining database links

The database is the normal tool to store repeated information and spreadsheet is the best place to 
carry out calculations. Using the database links, you can combine these tools in an efficient and 
powerful way (for an example on how to make links to database, see linking from a spreadsheet to a 
database). The notes below show how the example can be refined.

1. The number of matching records can be calculated in advance using the following formula:

=ROWS(DBSQLFILTER("accounts.adb", "invoices", "custid=1024", "invtotal"))
2. If there are many matching invoices, the ROW function can be used to propagate the formula. For 

example, suppose record one was entered in row 10. You could use the following:

=DBSQLFILTER("accounts.adb", "invoices", "custid=1024", "invtotal", ROW()-9)

When this cell is copied down the spreadsheet, the appropriate record will be displayed.

3. It could be more efficient if some of the parameters were entered separately in spreadsheet cells. 
For example, cells A1 through A5 could contain the following text/formulae:

Once A5 was copied down and across (with the correct field names), you could enter a new 
customer ID in cell A3 and analyze a different customer.

4. Taking step 3 a bit further, you could insert a mail merge field that stepped through each customer 
and so printed out a "payment history". Follow these steps:

a) Select Field from the Insert menu.

b) Enter custfield as the field name. This is actually the name of the new field, not the database 
field to be linked to, so you can choose any name you like.

c) Select the Database radio button and then click Next.
d) Make the link: pick the accounts database, the invoice table and the custid field and click 

Finish.

e) Substitute the following formula for cell A4 (in step 3 above):

=SSGET("spread1", "custfield")

where spread1 is the name of the current spreadsheet and custid is the

f) Select the Mail Merge button  or the Mail Merge button from the Tools menu.

g) Select Print to finish the mail merge.



Using one way links in formulas

One way (but not two way) links can be used as part of a standard formula. In addition, because the 
link functions can return ranges as well as individual cells, you can apply any function that has a range 
as a parameter directly to the link. For example, using the following spreadsheet called quarter:

When building a formula in another spreadsheet or a field in a Write document, treat the link function like 
any other. For example:

=10+SSGET("Quarter", "B3") / 2
To count, total, average and find the maximum volumes, refer to the range and use the built-in 
functions:

=ROWS(SSGET("Quarter", "B2..B5"))
=TOTAL(SSGET("Quarter", "B2..B5"))
=AVERAGE(SSGET("Quarter", "B2..B5"))
=MAX(SSGET("Quarter", "B2..B5"))

The same ideas can be applied to a database table. Consider the following invoice table in an accounts
database:

The table information can be referred to in the following ways:
=10+DBGET("accounts.adb", "invoices", "invtotal", 3) / 2

to reuse the invoice total field from row 3 (that is the value 8.50) in a formula and:

=ROWS(DBGET("accounts.adb", "invoices", "invtotal"))
=TOTAL(DBGET("accounts.adb", "invoices", "invtotal"))
=AVERAGE(DBGET("accounts.adb", "invoices", "invtotal"))
=MAX(DBGET("accounts.adb", "invoices", "invtotal"))

to find the number of records, the total, average and maximum of the invoice totals.



Two way links

A two way link is a connection between the current field and a field in another – or the same – 
document . If you change the value of either field, the value in the other field will also change.

A two way link cannot be used as part of a formula like a one way link can (see using one way links in 
formulas). Apart from this, you build two links in the same way as one way links as follows:

1. Create a normal one way link (see one way links for more details).

2. Turn the edit source property on:

· In a spreadsheet, use the Edit Source button  or select the Edit Source property in the 
Format/Attributes dialog.

· In a Write document, double-click on the field, select Attributes from the Field menu and 
select the Edit Source property.

For example, consider the following database table, called invoices:

1. In a spreadsheet cell, enter the following formula:

=DBGET("accounts.adb", "invoices", "invtotal", 3)
2. The result of the formula, 8.5, will be displayed. 

3. Click on the Edit Source button.

4. You can now enter a new value in the cell and the database will be updated.



Linking and embedding documents
Often, you may find you need to insert a chart or part of a spreadsheet (or both) into a report you're 
creating with Write. It could be that you want to create a new spreadsheet that only exists within the 
current document or you may want to insert a spreadsheet that you've already created. Further, you 
may want the document to automatically update should the original spreadsheet change.

These are all examples of a standard Windows technique called Object Linking and Embedding (or 
OLE for short) that Ability uses to enable such documents to be created. The Object refers to the 
spreadsheet, Embedding refers to the inclusion of an object within the current document (the first two 
examples above) and Linking refers to the "live" display of external data (the final example above).

All the Ability applications support OLE to some extent, as do many other non-Ability applications 
(meaning that Ability can share data with other applications).

Here’s a list of what can be inserted where:
Application Include objects from
Write Spreadsheet (including charts), Draw and 

any external applications that support 
OLE 

Spreadsheet Write, Draw and any external applications 
that support OLE

Database OLE field Spreadsheet (including charts), Write, 
Draw and any external applications that 
support OLE

Draw (and Database forms) Spreadsheet, Chart, Write and any 
external applications that support OLE

External programs (non -Ability
applications supporting OLE).

Write, Spreadsheet, Chart, and Draw.

For more information on linking and embedding, see:

Object linking 

Object embedding 

For examples of how this can be put into practice (it's much easier to do than the terminology might 
suggest), see one of the following:

Inserting a spreadsheet into a Write document 

Inserting a chart into a Write document 

Inserting a Draw document into Write or Spreadsheet 

Inserting an image into Write or Speadsheet 



Object linking

When an object is linked, the source data continues to reside physically wherever it was initially 
created. Only a reference, or link, to the object is kept with the compound document (along with 
appropriate presentation data). Linked objects cannot "travel" with documents to another machine; they
must remain within the local file system or be copied explicitly.

Linking is efficient and keeps the size of the compound document small. 

You may choose to link when the source object is owned or maintained by someone else, so that a 
single instance of the object’s data can serve many documents. 

Changes made to the source object are automatically reflected in any compound documents that have 
a link to the object.

To link an object:

1. Select Object from the Insert menu:

2. Select the Create from File radio button.

3. Make sure the Link box is checked.

4. Select the Browse button to locate the source object (for example, if you are embedding an Ability 
spreadsheet, you should be looking for a document with an AWS extension).

5. Select OK to insert and link the object.

See also:

Object embedding 



Object embedding

When an object is embedded, a copy of the original object is stored physically in the compound 
document, along with all the information needed to manage the object. As a result, the object becomes 
a physical part of the document. A compound document containing embedded objects will be larger 
than one containing the same objects as links. 

However, embedding offers several advantages that may outweigh the disadvantages of the extra 
storage overhead. For example, new objects can inserted as needed and compound documents with 
embedded objects may be transferred to another computer and edited there.

To embed an object, select Object from the Insert menu and do one of the following:

· Create and embed a new object
1. Select the Create New radio button.

2. Select the object type – this can be Ability Spreadsheet, Write or Draw or an object from any 
other application listed.

3. Click OK to embed the new object.

· Embed an existing object
1. Select the Create from File radio button.

2. Make sure the Link checkbox is clear.

3. Select the Browse button to locate the source object (for example, if you are embedding an 
Ability spreadsheet, you should be looking for a document with an AWS extension).

4. Click OK to embed the object.

See also:

Object linking 



Inserting a spreadsheet into a Write document

To insert a spreadsheet into a Write document, position the cursor in the Write document at the point 
where you want the spreadsheet to go and do one of the following:

· Insert a new spreadsheet 
Select the Spreadsheet/Chart option from the Insert menu. A standard spreadsheet will appear 
ready for entering the spreadsheet data.

· Insert an existing spreadsheet
1. Select Object from the Insert menu.

2. Select Create from File.

3. Click on the Browse button to choose the spreadsheet.

4. Optional – if you want the spreadsheet to be linked, check the Link box (see object linking for 
details on what this means).



Inserting a chart into Write

Since a chart is always attached to a spreadsheet, you insert a chart into a Write document in by first 
inserting the spreadsheet and then selecting or creating the chart to display. See Inserting a 
spreadsheet into a Write document for the details on how to insert the spreadsheet.

Immediately after insertion the spreadsheet will be in edit mode. This means you can make change to 
the spreadsheet rather than the document. If you drop out of edit mode (by clicking in another part of 
the document for example) double-click on the spreadsheet again to make it active.

The next step depends on whether you're creating a new chart or displaying an existing chart as 
follows:

· Creating a new chart
Select the figures you want to chart (or type them in if it's a new spreadsheet). Select As New View
from the Insert / Chart menu. Follow the steps in the chart wizard to create the appearance you 
want. See charts for more detail on how to do create charts.

· Displaying an existing chart
Once a spreadsheet has been inserted, you can choose which view you'd like to show in the 
document. Select Sheet from the View menu to display the normal spreadsheet grid. Select Chart 
from the View menu to view the chart. If there is more than one chart, you will be prompted to 
make a selection.



Inserting a Draw document into Write or Spreadsheet

To insert a Draw document into a Write document or spreadsheet, position the cursor at the point 
where you want the Draw document to appear and do one of the following:

· Insert a new draw document 
Select Drawing from the Insert menu. A standard draw document will appear ready for creating a 
new drawing – see Draw .for more details on how to create a drawing.

· Insert an existing draw document
1. Select Object from the Insert menu.

2. Select Create from File.

3. Click on the Browse button to choose the draw document.

4. Optional – if you want the drawing to be linked, check the Link box (see object linking for 
details on what this means).



Inserting an image into Write or Spreadsheet

An image (or picture) can be inserted directly into a Write document and (via Draw ) into a spreadsheet.

An image is file in one of the following formats:
BMP Windows Bitmap
WMF Windows Meta File
DIB Device Independent Bitmap
TIF Tagged Image File Format
GIF CompuServeÔ
TGA Targa 
PCX PC PaintbrushÔ

· Inserting into Write
1. Select Picture from the Insert menu.

2. Double-click on the image you want (or first browse to the folder where the image resides if 
necessary).

3. Once inserted, you can scale the image to the size you need by dragging the picture's handles.

· Inserting into Spreadsheet
1. Select Drawing from the Insert menu. A new, blank draw document will be inserted.

2. With the draw document still active, select Picture from the Insert menu in the same as 
described for inserting into Write above.

Note: both Spreadsheet and Write support the pasting of images via the clipboard. 



Fields – an introduction
Fields are common throughout Ability. The most obvious example of a field is a cell in a spreadsheet – it
can contain plain text, numbers or dates or it can display the result of a formula. The same is true of 
formula fields in Write and Database forms.

Fields share common properties – fonts, borders, colors, numeric formatting, alignment – throughout 
the Ability applications.

There are other properties of fields that are specific to a particular function. For example, a mail merge 
field (which allows database information to be browsed and merge printed in Write and Spreadsheet) 
has a source database, table and field.

Another powerful property of fields is their ability to refer to, or link to, fields in other documents and 
applications – see linking through fields.

Here are some examples of fields:
Application Description Created through
Write Date and time field Insert/Date and Time

Mail merge field Insert/Mail Merge
Formula field Insert/Field – this is the 

standard field that can 
be used for formulas 
and links.

Spreadsheet Cells Always present
Floating field – can be used to 
mail merge or browse 
database information or as a    
separate store of information 
to the standard spreadsheet 
cell.

Insert/Field – select 
either the Formula or 
Database field type in 
the field wizard.

Database Formula field in forms – 
equivalent to a standard field 
in Write.

Insert/Formula Field 
when in forms design 
mode.

Lookup Summary field – joins 
the current table to a another 
table to provide group 
summary information.

Insert/Lookup Summary 
Field – available in both 
forms and report design 
mode.



Field controls

A field control type governs the how the field information is editable by the user. The type is set when 
creating the field in the third page of the Insert Field wizard.

The control type can be any of the following:

· Edit box 
This is the standard field that can contain text, numerics, formula or database information. After 
selecting this, the next page of the wizard will offer options for Lock , Hide, Hide Zeros and Hide 
Errors, Edit Source (for setting up two way links), and Show as control if inactive.

For example, if you have set up a database field in a Write or Spreadsheet document and then 
switch on Edit Source, you can enter data at either end of the link and it will be reproduced at the 
other end. In this way you can change the data in a field in a database from the field you have 
created in a Write or Spreadsheet document.

· Checkbox 

Allows you to insert a checkbox field into a document and to determine how it should work. 
Checkboxes are useful when you want a field in your document to indicate that another field or a 
piece of text or data is in one of two states.

The checkbox has two states: Checked (marked with a tick) or Unchecked (checkbox is empty). 
The mouse can be used to check or uncheck a checkbox, when the checkbox is selected in your 
document. By default, the checkbox will display either True or False when in display mode in your 
document, but you can choose whether to have it display True, Yes or 1, or False, No or 0. Type 
your display choice in the Display choice, using one of these options.

It is also possible to have a checked box represent False (No, 0) and an unchecked box represent 
True (Yes, 1). Select your choice from the drop down list attached to the two options under Check. 
In this case it is best to type in a appropriate display choice in Display choice to match the options
in Check. Note that changing the value in Checked automatically causes the opposite value to be 
selected in Unchecked.

Once you have set up the checkbox, whenever you check it by clicking on it with the mouse, or 
type a value from the available options in the Formula Entry Bar, the checkbox will display the 
matching value from Display choice in your document.

You can also choose to have a checkbox indicate @Empty or @Not Empty, using either True or 
False in Display choices.

· Listbox
Allows you to scroll through a list defined by yourself, or the records under one field of a database 
with the option to display another field from the same record in the database.

Once you have selected Listbox, go to the next page and click on Use Choices in the Control 
Source group box. The Choices box will be highlighted. Here you can enter, line by line, any list 
you want, for example, the names of members of your family.

If you want to scroll through a list from a particular database field, then click on Lookup Choices. 
Click on the button attached to the Lookup Database box to select a database. Use the arrow 
attached to the Lookup Source box to find a table within the database. Select a field from Lookup 
Field: this field contains the list of values through which you can scroll. In the Display Field box 
choose the display field, which will correspond to the lookup field i.e. you can scroll through a list of
surnames from a database in the lookup field but display the first names from the display field. 
Once the field is inserted in a document, use the Page Up / Page Down or the arrow keys to move 
through the list.

· Combo
option allows you to scroll through a list defined by yourself, or the records under one field of a 



database with the option to display another field from the same record in the database. This is the 
same as for Listbox, except that in addition Combo enables you to access a drop-down menu 
which displays all the items in the display list.

Once you have selected Combo, click on Use Choices in the Control Source group box. The 
Choices box will be highlighted. Here you can enter, line by line, any list you want, for example, the
names of members of your family.

If you want to scroll through a list from a particular database field, then click on Lookup Choices. 
Click on the button attached to the Lookup Database box to select a database. Use the arrow 
attached to the Lookup Source box to find a table within the database. Select a field from Lookup 
Field: this field contains the list of items which you can use to look up or refer to the items in the 
display field. In the Display Field box choose the display field, which will correspond to the lookup 
field i.e. you can type a name from a list of first names from a database but display the surname to 
which the first name is attached.

Once the field is inserted into a document, click on the arrow attached to the field to access the 
drop-down menu of all the items in the display list. Alternatively, type a lookup item in the entry box 
at the bottom left of the window and press return to display the associated display item.

Note: You can set Editbox options in conjunction with Checkbox, Listbox and Combo.

When a field is inserted into a document it can be in one of two modes: active and display. In active 
mode the field is selected and is available for editing and for the input of data. In display mode the field 
displays its results. To activate a field double click on it; to display a field click once outside it.

To edit a field you should first select it by double clicking in the field. The Field menu option is displayed
along the top of the window. Clicking on any of the options in the Field menu brings up the "Field 
Attributes" dialog. In here you can change or add to attributes already set. The following options are 
available:

General contains details of the field type - either formula or database - and field name. You can change
these here.

Color allows you to select a color for the field.

Font enables you to choose a font and special effects for text within the field.

Border contains various border types for the field.

There are also options for Alignment, Style, Control, Attributes, and Format.




